MLflow 1.7.2 is a patch release containing a minor change:

  • Pin alembic version to 1.4.1 or below to prevent pep517-related installation errors (#2612, @smurching)

For a comprehensive list of changes, see the release change log, and check out the latest documentation on mlflow.org.