We are happy to announce the availability of MLflow 1.20.1!

MLflow 1.20.1 is a patch release containing the following bug fixes:

  • Avoid calling importlib_metadata.packages_distributions upon mlflow.utils.requirements_utils import (#4741, @dbczumar)
  • Avoid depending on importlib_metadata==4.7.0 (#4740, @dbczumar)

For a comprehensive list of changes, see the release change log, and check out the latest documentation on mlflow.org.